Problem A: Hello world!
Description
Xiao_ming有两个哥哥,大哥叫Da_min,二哥叫Er_min。三兄弟放学回家,父母分别跟他们打招呼。叫外卖
Input
无
Output
请输出:
Hello Da_min,
Hello Er_min,
Hello Xiao_ming!
Sample Input
手抄报元宵节Sample Output
Hello Da_min,
Hello Er_min,
Hello Xiao_ming!
HINT
请注意换行符
#include <stdio.h>
int main()
{
printf("Hello Da_min,\nHello Er_min,\nHello Xiao_ming!");
手机吉他
}
Problem A: 算术基本运算
Description
丝瓜汤的做法计算两整数x和y(0<x,y<1000)的和、差、积、商、余数、x的平方和y的三次方。
Input
输入只有一行,格式见sample。
Output
输出为多行,按顺序每行输出x,y的和、差、积、商、余数、x的平方和y的三次方,格式见sample
Sample Input
x = 11, y = 3
Sample Output
x + y : 14
x - y : 8
x * y : 33
x / y quotient: 3, remainder: 2
x ^ 2 : 121
y ^ 3 : 27
HINT
注意输入输出格式。了解C语言整数除法运算符的特点,并且没有求幂的运算符。
#include <stdio.h>
int main()
{
int x,y;
scanf ("x = %d, y = %d",&x,&y);
printf ("x + y : %d\n",x+y);
printf ("x - y : %d\n",x-y);
printf ("x * y : %d\n",x*y);
printf ("x / y quotient: %d, remainder: %d\n",x/y,x%y);
printf("x ^ 2 : %d\n",x*x);
杨颖的国籍 printf ("y ^ 3 : %d\n",y*y*y);
}
Problem B: 求圆的面积和周长
Description
从键盘输入圆的半径,求圆的面积和周长,圆周率取3.14。
Input
输入一个浮点型数据,有效数字不会超过十进制的6位。
Output
输出为两行。
第一行为圆的面积,第二行为圆的周长,格式见sample。
Sample Input
3
Sample Output特色专业
Area: 28.260000
Perimeter: 18.840000
HINT
了解浮点类型的输入、输出和算术运算符
#include <stdio.h>
#define PI 3.14
int main()
{
float r,Area,Perimeter;
scanf ("%f",&r);
Area=PI*r*r;
Perimeter=2*PI*r;
printf ("Area: %f\n",Area);
printf ("Perimeter: %f\n",Perimeter);
}
Problem C: 平均值
Description
求3个数的平均值。
Input
输入只有一行,为3个较小的整数。
Output
输出为这3个整数的平均值,保留3位小数。
Sample Input
1 2 3
Sample Output
泰加林
2.000
#include <stdio.h>
int main()
{
int x,y,z;
float a;
scanf ("%d %d %d",&x,&y,&z);
a=(x+y+z)/3.0;
printf ("%.3f",a);
}
Problem D: 货币兑换
Description
给出人民币对美元、欧元、日元的当日汇率,求给定金额的人民币能兑换成外币的金额,求给定金额的外币能兑换成人民币的金额。重要的用英语怎么说
要计算的外币有三种:美元、欧元、日元。